Mise à jour de Sécurité 2007-009

mardi 18 décembre 2007 par Jade

Vos appliquez, en général, ces mises à jour sans consulter le détail de ce qu’elles apportent, vous saurez donc que Security Update 2007-009 corrige de nombreuses failles de sécurité à en croire le détail de cette mise à jour :

- Carnet d’adresses

Références CVE : CVE-2007-4708

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : la consultation d’un site web construit de manière malveillante peut conduire à un blocage inattendu d’application ou à l’exécution de code quelconque

Description : il existe une vulnérabilité de chaîne de format dans le gestionnaire d’URL du Carnet d’adresses. En poussant un utilisateur à visiter un site web construit de manière malveillante, un attaquant distant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque. Cette mise à jour corrige le problème par une gestion améliorée des chaînes de format. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- CFNetwork

Références CVE : CVE-2007-4709

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : la visite d’un site web malveillant peut permettre le téléchargement automatique de fichiers vers des dossiers quelconques pour lesquels l’utilisateur dispose d’une autorisation en écriture

Description : il existe un problème de parcours de chemin au niveau de la gestion par CFNetwork des fichiers téléchargés. En poussant un utilisateur à visiter un site web malveillant, un attaquant peut provoquer le téléchargement automatique de fichiers vers des dossiers quelconques pour lesquels l’utilisateur dispose d’une autorisation en écriture. Cette mise à jour résout le problème par une amélioration du traitement des réponses HTTP. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Sean Harding pour avoir signalé ce problème.

- ColorSync

Références CVE : CVE-2007-4710

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’affichage d’une image construite de manière malveillante avec un profil ColorSync intégré peut conduire à un blocage inattendu d’application ou à l’exécution de code quelconque

Description : il existe un problème de corruption de la mémoire dans la gestion d’images avec un profil ColorSync intégré. En poussant un utilisateur à ouvrir une image construite de manière malveillante, un attaquant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant des validations supplémentaires sur les images. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur. Nous remercions Tom Ferris de ASSET (Adobe Secure Software Engineering Team) pour avoir signalé ce problème.

- Core Foundation

Références CVE : CVE-2007-5847

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’utilisation de l’API CFURLWriteDataAndPropertiesToResource peut conduire à la divulgation d’informations sensibles

Description : il existe dans l’API CFURLWriteDataAndPropertiesToResource une situation de concurrence qui peut provoquer la création de fichiers avec des autorisations non sécurisées. Cela peut conduire à la divulgation d’informations sensibles. Cette mise à jour résout le problème via une amélioration de la gestion des fichiers. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- CUPS

Références CVE : CVE-2007-5848

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : un administrateur local peut obtenir des privilèges système

Description : il existe un problème de dépassement de la mémoire tampon dans le gestionnaire d’imprimante de CUPS. Cela peut permettre à un administrateur local d’obtenir des privilèges système en transmettant au service CUPS une URI construite de manière malveillante. Cette mise à jour corrige le problème en assurant que la taille de la mémoire tampon de destination est adaptée aux données. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur. Nous remercions Dave Camp de Critical Path Software pour avoir signalé ce problème.

- CUPS

Références CVE : CVE-2007-4351

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : un attaquant distant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque

Description : il existe au niveau de la gestion des balises IPP (Internet Printing Protocol) un problème de corruption de la mémoire qui peut permettre à un attaquant distant de provoquer un blocage inattendu d’application ou l’exécution de code quelconque. Cette mise à jour résout le problème via une amélioration des contrôles de limitation des zones adressables.

- CUPS

Références CVE : CVE-2007-5849

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : si SNMP est activé, un attaquant distant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque

Description : Le programme SNMP d’arrière-plan de CUPS diffuse des requêtes SNMP pour détecter les serveurs d’impression réseau. Un dépassement inférieur d’entier au niveau de la gestion des réponses SNMP peut provoquer un dépassement de mémoire tampon dans la pile. Si SNMP est activé, un attaquant distant peut exploiter ce problème en envoyant une réponse SNMP construite de manière malveillante, ce qui peut provoquer un blocage d’application ou l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant des validations supplémentaires sur les réponses SNMP. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Wei Wang de McAfee Avert Labs pour avoir signalé ce problème.

- Desktop Services

Références CVE : CVE-2007-5850

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’ouverture dans le Finder d’un répertoire contenant un fichier .DS_Store construit de manière malveillante peut conduire à l’exécution de code quelconque

Description : il existe un dépassement de mémoire tampon dans Desktop Services. En poussant un utilisateur à ouvrir un répertoire contenant un fichier .DS_Store construit de manière malveillante, un attaquant peut provoquer l’exécution de code quelconque. Cette mise à jour résout le problème via une amélioration des contrôles de limitation des zones adressables. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- Module externe Flash Player

Références CVE : CVE-2007-5476

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Description : Adobe Flash Player est mis à jour vers la version 9.0.115.0 pour traiter la vulnérabilité CVE-2007-5476. Vous trouverez des informations complémentaires sur le site d’Adobe à l’adresse http://www.adobe.com/support/security/advisories/apsa07-05.html. Nous remercions Opera Software pour avoir signalé ce problème.

- GNU Tar

Références CVE : CVE-2007-4131

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’extraction d’une archive tar construite de manière malveillante peut écraser des fichiers quelconques

Description : il existe un problème de parcours de répertoire dans GNU Tar. En poussant un utilisateur local à extraire une archive tar construite de manière malveillante, un attaquant peut provoquer l’écrasement de fichiers quelconques. Ce problème a été résolu par des validations supplémentaires sur les fichiers tar. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- iChat

Références CVE : CVE-2007-5851

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : une personne sur le réseau local peut lancer une connexion vidéo sans l’approbation de l’utilisateur

Description : un attaquant sur le réseau local peut lancer une vidéoconférence avec un utilisateur sans l’approbation de ce dernier. Cette mise à jour résout le problème en demandant une interaction de l’utilisateur pour lancer une vidéoconférence. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- Gamme de stockage E/S

Références CVE : CVE-2007-5853

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’ouverture d’une image disque construite de manière malveillante peut conduire à un arrêt inattendu du système ou à l’exécution de code quelconque

Description : il existe un problème de corruption de la mémoire dans la gestion des cartes de partition GUID au sein d’une image disque. En poussant un utilisateur à ouvrir une image disque construite de manière malveillante, un attaquant peut provoquer un arrêt inattendu du système ou l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant une validation supplémentaire sur les cartes de partition GUID. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- Launch Services

Références CVE : CVE-2007-5854

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : l’ouverture d’un fichier HTML construit de manière malveillante peut conduire à la divulgation d’informations ou à un scriptage intersite

Description : Launch Services ne gère pas les fichiers HTML comme du contenu potentiellement non sécurisé. En poussant un utilisateur à ouvrir une page web construite de manière malveillante, un attaquant peut provoquer la divulgation d’informations sensibles ou un scriptage intersite. Cette mise à jour résout le problème en gérant les fichiers HTML comme du contenu potentiellement non sécurisé. Nous remercions Michal Zalewski de Google Inc. pour avoir signalé ce problème.

- Launch Services

Références CVE : CVE-2007-6165

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : l’ouverture d’un fichier exécutable joint à un courrier électronique peut conduire à l’exécution de code quelconque, sans avertissement préalable

Description : il existe dans Launch Services un problème d’implémentation pouvant permettre le lancement, sans avertissement préalable, d’un fichier exécutable joint à un courrier électronique lorsqu’un utilisateur ouvre une pièce jointe. Cette mise à jour résout le problème en avertissant l’utilisateur avant le lancement d’un fichier exécutable joint à un courrier électronique. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Xeno Kovah pour avoir signalé ce problème.

- Mail

Références CVE : CVE-2007-5855

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : les comptes SMTP configurés via l’assistant Ajouter un compte peuvent utiliser une authentification en texte clair, même si l’authentification Réponse au défi MD5 est disponible

Description : lors de la configuration d’un compte SMTP via l’assistant Ajouter un compte, si l’authentification SMTP est sélectionnée et que le serveur ne gère que l’authentification Réponse au défi MD5 et en texte clair, Mail utilise par défaut l’authentification en texte clair. Cette mise à jour résout le problème en s’assurant que le mécanisme le plus sécurisé disponible est utilisé. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- perl

Références CVE : CVE-2007-5116

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : l’analyse d’expressions régulières peut conduire à l’exécution de code quelconque

Description : il existe un problème de calcul de longueur au niveau de la gestion des opcodes polymorphiques dans le compilateur d’expressions régulières Perl. Cela peut permettre à un attaquant de provoquer une corruption de la mémoire conduisant à l’exécution de code quelconque en passant des octets aux caractères Unicode (UTF) dans une expression régulière. Cette mise à jour résout le problème en recalculant la longueur en cas de changement de l’encodage des caractères. Nous remercions Tavis Ormandy et Will Drewry de l’équipe sécurité de Google pour avoir signalé ce problème.

- python

Références CVE : CVE-2007-4965

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : le traitement du contenu image avec le module imageop peut conduire à un blocage inattendu d’application ou à l’exécution de code quelconque

Description : il existe plusieurs dépassements d’entier dans le module imageop de python. Cela peut provoquer un dépassement de mémoire tampon dans les applications utilisant ce module pour traiter un contenu image construit de manière malveillante. Cela peut conduire à un blocage inattendu d’application ou à l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant des validations supplémentaires sur le contenu image.

- Quick Look

Références CVE : CVE-2007-5856

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : la prévisualisation d’un fichier avec Quick Look activé peut conduire à la divulgation d’informations sensibles

Description : lors de la prévisualisation d’un fichier HTML, les modules externes peuvent effectuer des requêtes réseau. Cela peut conduire à la divulgation d’informations sensibles. Cette mise à jour corrige le problème en désactivant les modules externes. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5.

- Quick Look

Références CVE : CVE-2007-5857

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : la prévisualisation d’un fichier séquence peut permettre d’accéder aux URL contenues dans la séquence

Description : la création d’une icône pour un fichier séquence ou la prévisualisation de ce fichier via Quick Look peut permettre d’accéder aux URL contenues dans la séquence. Cette mise à jour résout le problème en désactivant HREFTrack lors de l’exploration de fichiers séquences. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5 ou dans les systèmes sur lesquels QuickTime 7.3 est installé. Nous remercions Lukhnos D. Liu de Lithoglyph Inc. pour avoir signalé ce problème.

- ruby

Références CVE : CVE-2007-5770

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : multiples problèmes de validation de certificats SSL dans les bibliothèques ruby

Description : plusieurs bibliothèques ruby sont concernées par des problèmes de validation de certificats SSL. Cela peut provoquer des attaques de l’homme du milieu au niveau des applications qui utilisent une bibliothèque concernée. Cette mise à jour résout les problèmes en appliquant le correctif de ruby.

- ruby

Références CVE : CVE-2007-5379, CVE-2007-5380 et CVE-2007-6077

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : multiples vulnérabilités dans Rails 1.2.3

Description : il existe dans Rails 1.2.3 plusieurs vulnérabilités qui peuvent conduire à la divulgation d’informations sensibles. Cette mise à jour résout le problème en mettant à jour Rails avec la version 1.2.6. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5.

- Safari

Références CVE : CVE-2007-5858

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : la visite d’un site web construit de manière malveillante peut conduire à la divulgation d’informations sensibles

Description : WebKit permet à une page d’accéder aux sous-cadres d’autres pages. La visite d’une page Web construite de manière malveillante peut déclencher une attaque de scriptage intersite et ainsi conduire à la divulgation d’informations sensibles. Cette mise à jour résout le problème en implémentant une stratégie plus stricte au niveau de la navigation dans les cadres.

- RSS Safari

Références CVE : CVE-2007-5859

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : l’accès à une URL de flux construite de manière malveillante peut conduire à un blocage d’application ou à l’exécution de code quelconque

Description : il existe un problème de corruption de la mémoire au niveau de la gestion par Safari des URL de flux. En poussant un utilisateur à accéder à une URL construite de manière malveillante, un attaquant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant des validations supplémentaires sur les URL de flux et en affichant un message d’erreur en cas d’URL non valide. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- Samba

Références CVE : CVE-2007-4572, CVE-2007-5398

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : multiples vulnérabilités dans Samba

Description : Il existe plusieurs vulnérabilités dans Samba, la plus importante étant l’exécution de code à distance. Cette mise à jour résout les problèmes en appliquant les correctifs du projet Samba. Pour plus d’informations, consultez le site web de Samba à l’adresse http://www.samba.org/samba/history/security.html. La vulnérabilité CVE-2007-4138 est absente dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Alin Rad Pop de Secunia Research pour avoir signalé ce problème.

- Module externe Shockwave

Références CVE : CVE-2006-0024

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11, Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : l’ouverture d’un contenu Shockwave construit de manière malveillante peut conduire à l’exécution de code quelconque

Description : il existe plusieurs vulnérabilités dans Shockwave Player. En poussant un utilisateur à ouvrir un contenu Shockwave construit de manière malveillante, un attaquant peut provoquer l’exécution de code quelconque. Cette mise à jour résout les problèmes en mettant à jour Shockwave Player avec la version 10.1.1.016. Nous remercions Jan Hacker de ETH Zurich pour avoir signalé le problème dans Shockwave.

- SMB

Références CVE : CVE-2007-3876

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : un utilisateur local peut exécuter un code quelconque avec des privilèges système

Description : il existe un problème de dépassement de la mémoire tampon de la pile au niveau du code utilisé par les applications mount_smbfs et smbutil pour analyser les arguments de ligne de commande. Ce problème peut permettre à un utilisateur local de provoquer l’exécution de code quelconque avec des privilèges système. Cette mise à jour résout le problème via une amélioration des contrôles de limitation des zones adressables. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur. Nous remercions Sean Larsson de VeriSign iDefense Labs pour avoir signalé ce problème.

- Mise à jour de logiciels

Références CVE : CVE-2007-5863

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : une attaque de l’homme du milieu peut pousser Mise à jour de logiciels à exécuter des commandes quelconques

Description : lorsque Mise à jour de logiciels recherche de nouvelles mises à jour, il traite un fichier de définition de distribution envoyé par le serveur de mise à jour. En interceptant les requêtes envoyées au serveur de mise à jour, un attaquant peut fournir un fichier de définition de distribution construit de manière malveillante et comportant l’option « allow-external-scripts », qui peut provoquer l’exécution de commandes quelconques lorsqu’un système recherche les nouvelles mises à jour. Cette mise à jour résout le problème en désactivant l’option « allow-external-scripts » dans Mise à jour de logiciels. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Moritz Jodeit pour avoir signalé ce problème.

- Spin Tracer

Références CVE : CVE-2007-5860

Disponible pour : Mac OS X v10.5.1, Mac OS X Server v10.5.1

Conséquences : un utilisateur local peut exécuter un code quelconque avec des privilèges système

Description : il existe une opération de fichier non sécurisée au niveau de la gestion par SpinTracer des fichiers de sortie, qui peut permettre à un utilisateur local d’exécuter un code quelconque avec des permissions système. Cette mise à jour résout le problème par une amélioration de la gestion des fichiers de sortie. Ce problème est absent dans les systèmes antérieurs à Mac OS X 10.5. Nous remercions Kevin Finisterre de DigitalMunition pour avoir signalé ce problème.

- Spotlight

Références CVE : CVE-2007-5861

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : le téléchargement d’un fichier .xls construit de manière malveillante peut conduire à un blocage inattendu d’application ou à l’exécution de code quelconque

Description : il existe un problème de corruption de la mémoire dans l’outil d’importation Spotlight de Microsoft Office. En poussant un utilisateur à télécharger un fichier .xls construit de manière malveillante, un attaquant peut provoquer un blocage inattendu d’application ou l’exécution de code quelconque. Cette mise à jour résout le problème en réalisant des validations supplémentaires sur les fichiers .xls. Ce problème est absent dans les systèmes Mac OS X 10.5 ou ultérieur.

- tcpdump

Références CVE : CVE-2007-1218, CVE-2007-3798

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : multiples vulnérabilités dans tcpdump

Description : Il existe plusieurs vulnérabilités dans tcpdump, la plus importante pouvant conduire à l’exécution de code quelconque. Cette mise à jour résout le problème en mettant à jour tcpdump avec la version 3.9.7. Ce problème est absent dans les systèmes exécutant Mac OS X 10.5 ou ultérieur.

- XQuery

Références CVE : CVE-2007-1659, CVE-2007-1660, CVE-2007-1661, CVE-2007-1662, CVE-2007-4766, CVE-2007-4767, CVE-2007-4768

Disponible pour : Mac OS X v10.4.11, Mac OS X Server v10.4.11

Conséquences : multiples vulnérabilités au niveau de la gestion des expressions régulières

Description : il existe plusieurs vulnérabilités au niveau de la bibliothèque PCRE (Perl Compatible Regular Expressions) utilisée par XQuery, la plus importante pouvant conduire à l’exécution de code quelconque. Cette mise à jour résout le problème en mettant à jour PCRE avec la version 7.3. Pour plus d’informations, consultez le site web de PCRE à l’adresse http://www.pcre.org/. Ce problème est absent dans les systèmes exécutant Mac OS X 10.5 ou ultérieur. Nous remercions Tavis Ormandy et Will Drewry de l’équipe sécurité de Google pour avoir signalé ce problème.

 

Accueil | Contact | Plan du site | Espace privé |

SPIP

RSSfr

Vous êtes le Site Meter visiteur.